Opened 9 years ago

Last modified 9 years ago

#79 new defect

canceling debirf with "ctrl-C" breaks fakeroot

Reported by: jrollins Owned by: jrollins
Priority: major Component: debirf
Keywords: Cc:
Sensitive:

Description

after canceling a debirf build in the middle of the build with "ctrl-C", fakeroot becomes broken:

servo:/srv/debirf/xkiosk 0$ debirf m -s -d .
Loading profile '.'...
debirf: skipping debootstrap...
debirf: executing modules...
fakeroot, while creating message channels: No space left on device
This may be due to a lack of SYSV IPC support.
fakeroot: error while starting the `faked' daemon.
servo:/srv/debirf/xkiosk 1$ 

trying to run fakeroot outside of debirf produces the same error message. i have not been able to figure what exactly get broken, or how to fix it. so far the only solution i have found is to reboot.

Change History (2)

comment:1 Changed 9 years ago by dkg

Are you saying you need to reboot the host machine on which you are creating the fakeroot?

Can you reproduce this behavior without debirf? that is, can you reproduce it using only fakeroot?

For instance, i just tried the following sequence (the dd run was interrupted with ctrl-C), and didn't have any problem:

[0 dkg@squeak cdtemp.zu4848]$ fakeroot -i x -s x dd if=/dev/zero of=/dev/null
1485900+0 records in
1485899+0 records out
760780288 bytes (761 MB) copied, 1.9665 seconds, 387 MB/s
[130 dkg@squeak cdtemp.zu4848]$ fakeroot -i x -s x bash
[0 root@squeak cdtemp.zu4848]# exit
exit
[0 dkg@squeak cdtemp.zu4848]$ 

comment:2 Changed 9 years ago by jrollins

i didn't get a chance to try it outside of debirf yet. i'm reluctant to try it on my tpc until we figure out how to escape from it, since i don't want to have to reboot again.

Note: See TracTickets for help on using tickets.