Opened 11 years ago

Closed 10 years ago

#24 closed defect (fixed)

disable/enable cereal console produces error message

Reported by: Daniel Kahn Gillmor Owned by: Daniel Kahn Gillmor
Priority: major Component: cereal
Keywords: Cc: jrollins
Sensitive: no

Description

Something is looking in the wrong place when i enable/disable a cereal socket:

0 itchy:~# cereal-admin disable ida
Disabled session 'ida'.
0 itchy:~# cereal-admin enable ida
/usr/share/cereal/common: line 101: /var/service/cereal.ida/socket: No such file or directory
Enabled session 'ida'.
0 itchy:~# ls -la /var/service/cereal.ida/socket 
prw-r----- 1 idaconsole idaviewers 0 2007-05-10 22:18 /var/service/cereal.ida/socket
0 itchy:~# 

Change History (6)

comment:1 Changed 11 years ago by Daniel Kahn Gillmor

Cc: jrollins added
Component: CMRGcereal
Owner: changed from dkg,jrollins to Daniel Kahn Gillmor

comment:2 Changed 11 years ago by Daniel Kahn Gillmor

this seems to be a problem with cereal 0.6-1 (just built). I think it's a regression since 0.4-1

comment:3 Changed 11 years ago by Daniel Kahn Gillmor

This appears to be happening because of a log_write that's triggered before the session is properly reconnected.

From an invocation via bash -x cereal-admin enable rosa, i see this:

+ log_write rosa 'cereal: enabling session '\''rosa'\''...'
+ echo -e '\ncereal: cereal: enabling session '\''rosa'\''...'
/usr/share/cereal/common: line 101: /var/service/cereal.rosa/socket: No such file or directory

and i note that log_write (in /usr/share/cereal/common) is defined by dumping stuff to the socket. Is this really the right way to do this? If we could get screen to log to stdout (or stderr, or whatever), how would log_write work?

comment:4 Changed 11 years ago by jrollins

Resolution: fixed
Status: newclosed

This issue has been fixed in 0.7-1. The message is now written to the log right after the session has been enabled, so that the socket is available to write to.

I think that this method of writing to the logs is fine and works well. If we do ever figure out how to get screen to stdout we can reevaluate.

comment:5 Changed 10 years ago by Daniel Kahn Gillmor

Resolution: fixed
Status: closedreopened

This appears to be broken again as of [982], because the order got switched back to logging, then starting.

comment:6 Changed 10 years ago by Daniel Kahn Gillmor

Resolution: fixed
Status: reopenedclosed

I think i've fixed it again in [989]

Note: See TracTickets for help on using tickets.